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1 Wat is Lyx?
LATEX is een ’programmeertaal’ om documenten te programmeren (zoals HTML voor websites) en
Lyx kan bekeken worden als een grafische laag over LATEX. LATEX op zich is onoverzichtelijk voor
grote documenten, omdat de titels er niet uitspringen, de prentjes niet getoond worden,... Het is heel
gemakkelijk om in een groot LATEX bestand verloren te lopen. Lyx bevat de belangrijkste features van
LATEX voor het maken van documenten, maar laat de structuur in een bestand beter zien, waardoor
er efficiënter gewerkt kan worden.

1.1 Hoe installeren
De installer van Lyx kan gedownload worden op internet, maar met Lyx alleen kan er geen uiteindelijk
document gemaakt worden. Lyx genereert LATEX code, die LATEX code moet dan nog omgezet
worden naar bijvoorbeeld PDF. Hiervoor is een LATEX compiler nodig.

• Op windows heet de LATEX compiler MIKTEX.

• Op mac heb ik geen idee hoe de compiler heet, maar hij zal ook wel te vinden zijn.

Installeer MIKTEX eerst en daarna Lyx. Bij de installatie van Lyx zal gevraagd worden om naar de
map met de compiler te verwijzen, zodat hij weet wat te gebruiken. Als dit gebeurt is kan MIKTEX
vergeten worden, Lyx doet de nodige dingen er wel mee.

2 Tekst en Lay-out
In alle dingen die gebaseerd zijn op LATEX is het niet de gebruiker die de layout van een tekst
vastlegd, maar de computer die de inhoud zo goed mogelijk probeert weer te geven. Op die manier kan
de gebruiker zich volledig concentreren op de inhoud. Het enige dat de gebuiker zich moet aantrekken
van de Lay-out is een template kiezen. Elke template bevat alle regels voor het Lay-outen van een
tekst. De template bevat een aantal definities voor titels en types tekst die in een bestand kunnen
voorkomen. Begin dus bij het kiezen van een lay-out template. Dit kan als volgt:

1. Document→ Settings...

2. Bij Document class is er een drop-down menu. Dit bevat de mogelijke lay-outs die geinstalleerd
zijn in de compiler.

Kies er daar een uit. Deze tekst is gemaakt in de ’article’ template, de basistemplate waar ook de
cursussen van Yves in gemaakt zijn. Andere handige templates zijn de ’article (IEEEtran)’ voor IEEE
artikels en de ’book’ templates als een A5 pagina gewenst is.

Het is mogelijk om verdere instellingen van de lay-out aan te passen. Ik vind bijvoorbeeld dat de
marges te groot zijn bij de article layout, dus ik kan die als volgt aanpassen:

1. Document→ Settings...→ PageMargins

2. Haal het vinkje ’Default Margins’ weg en pas aan naar willekeur (in deze tekst zijn inner en outer
aangepast naar 3cm, de rest van de kadertjes liet ik leeg om de standaardinstelling te behouden)

De Document Settings bevatten veel instellingen, ga alle categorieën maar is af om te zien wat de
mogelijkheden zijn.
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2.1 Article tekst types

Om een tekst type in te stellen wordt het drop-down menu bovenaan gebruikt terwijl de aan te passen
tekst geselecteerd is of als de cursor in de aan te passen tekst staat.

De standaard tekst types worden ook opgesomd. Daarnaast bestaan er ook nog varianten met een
* bij. Deze komen overeen met hetzelfde als hun broertjes zonder *, maar dan zonder nummering erbij.
De vorige teksttypes komen in bijna alle templates voor. ’Article’ voegt er nog een paar aan toe om
de titel van het document aan de duiden alsook ’Author’ en ’Date’. IEEEtran voegt nog andere zaken
toe als ’theorem’ en ’proof’, maar meestal wijzen de tekst types zichzelf wel uit.

2.2 Bold, Emphasis en Kleur

Om stukken in een blok standaard tekst te accentueren zonder van een standaard teksttype gebruik
te maken bestaan bold en italic net zoals in word, maar in Lyx wordt italic emphasis genoemd. De
shortcut voor bold is ctrl + b. Die voor emphasis is ctrl + e. Kleur kan ingesteld worden via de
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’Text Style’. Selecteer de tekst die in een andere kleur moet en doe Edit → Text Style (er staat een
sneller knopje in de werkbalk bovenaan). Daar kan de kleur aangepast worden, alsook een hoop andere
dingen.

2.3 Marges en Dubbelzijdige lay-out

De standaard marges van de stijlen die in Lyx zitten vind ik meestal nogal groot. Het is mogelijk om
ze aan te passen naar betere instellingen in de document settings:

Document→ Settings...→ PageMargins

2.3.1 Lay-out voorbeeldblad

Het is mogelijk om een voorbeeldblad met de marges erop aan het document toe te voegen:

• Document→ Settings...→ LaTeX preamble

• Voeg \usepackage{layout} toe in de LATEX preamble

• Ga terug naar de gewone Lyx, liefst naar het begin van het document

• Voeg de LATEX code \layout toe (ga in LATEX mode door ctrl + L te gebruiken)

• Compileer de pdf

Er zal nu op de plaats waar de LATEX code geplaatst is een pagina getoond worden met de verschillende
marges erop.

2.3.2 Dubbelzijdig

Bij de marges werd er al een onderscheid gemaakt tussen de innner en outer marge. Deze komen echt
tot hun recht als een dubbelzijdig document gemaakt wordt.

• Document→ Settings...→ PageLayout

• Zet het vinkje ’Two-sided document’ aan.

2.4 Hyperref support

Om in de inhoudstabel te kunnen klikken op de titeltjes en dan naar het bijhorende titeltje te springen
in de tekst moet de hyperref support ingeschakeld worden. Dit kan als volgt

• Document→ Settings...→ PDF Properties

• Zet het vinkje ’Use hyperref support’ aan

• Ga naar Hyperlinks

• Zet het vinkje ’No frames around links’ aan om geen lelijke kadertjes rond de links te hebben in
de pdf
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3 Figuren
Figuren in Lyx bevinden zich altijd in een float. de layout legt regels vast voor het plaatsen van figuren
(bvb altijd bovenaan een pagina) en de compiler gaat de figuur zo dicht mogelijk bij de aangegeven
plaats in de tekst plaatsen zodat aan de regels voldaan is. Dit kan soms rare resultaten geven als er
weinig tekst is in verhouding tot het aantal figuren en er zijn mogelijkheden om u daarin te moeien,
maar die geven meestal nog ergere resultaten. Boodschap is: Aanvaard wat de compiler doet, het is
goed genoeg.

3.1 Floats
Een float kan als volgt ingevoerd worden: insert→ float→ figure (geen snelkoppeling bekend).

Er verschijnt een kadertje met een caption (berschrijving met een nummer) erin:

Het is nu mogelijk om de figuur zelf in te voegen. ze de cursor in de float (maar niet in de caption)
en doe insert→ graphics... Het volgende menutje verschijnt:

Browse naar de juiste afbeelding en duw OK. Bij het compileren gaat de figuur nu in zijn grootte
in de pfd geplaatst worden. dit kan gigantisch groot zijn. Om dit aan te passen is het best om ’set
width’ aan te vinken en in plaats van de grootte in cm in te geven is het mogelijk om de grootte in
functie van de textbreedte in te geven. Dit doe je met de ’Text Width %’. Een goed ingestelde figuur
ziet er als volgt uit:

Het is aan te raden om na het invoeren van de graphics, het prentje te centreren. dit kan als volgt:

1. Zet de cursor in de float, naast het ingevoerde prentje

2. Edit→ ParagraphSettings...

3. kies center
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4. OK

Als de figuur er in Lyx zelf te groot uit ziet is het mogelijk om die te verkleinen door ’Scale on Screen
(%)’ in te stellen in het tabje ’Latex and Lyx options’. Onthou dat dit niets te maken heeft met hoe
groot de figuur in de uiteindelijke pdf eruit zal zien.

3.2 Meerdere figuren in een float
Omdat je geen controle hebt over waar de figuren uiteindelijk komen, is het niet mogelijk om figuren
die bij elkaar horen in verschillende floats te zetten. Het is niet voldoende om gewoon twee keer
insert→ graphics... te doen, want de compiler doet er nog steeds zijn goesting mee binnenin de float.
Hier komen de minipages van pas:

1. Insert→ Float→ Figure

2. Plaats de cursor in de float, niet in de caption

3. Insert→ Box→ Frameless

4. Plaats de cursor in de float, niet in de caption of in de nieuwe box

5. Insert→ Formatting → Horizontal space→ Horizontal fill

6. Insert→ Box→ Frameless

7. Klik rechts op de minipages en stel de breedte in op 45% van de textwidth

8. Voer nu de graphics in in elke minipage, zoals in een float.

Uiteindelijk ziet de hele constructie er als volgt uit:
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De afbeeldingen in de ’Box (Minipage)’ voelen zich als in een nieuwe pagina. om de afbeelding de
volledige breedte van de box te geven, moet je de afbeelding 100% van de tekst width maken. Om de
afbeelding dan te schalen wordt best met de breedte van de box gespeeld, en niet met de afbeelding
zelf.

Het is mogelijk om de figuren nu elk een aparte caption te geven door in plaats van een frameless
box, een nieuwe figure float in te voeren in de moederfloat.

3.3 Afbeeldingsformaten

Omdat de afbeeldingen herschaald worden is het beter om de afbeeldingen in een vectorieel formaat
in een bestand te plaatsen. Voor figures uit MATLAB en ADS is de .emf extentie aan te raden. Yves
maakt zijn vectoriele afbeeldingen met het programma inkscape, maar daar moet iemand anders maar
is een cursus over maken. Als het echt niet vectorieel kan, gebruik dan een formaat met verliesloze
compressie als .png. Blijf zeker weg van jpeg.

3.3.1 Vanuit MATLAB

Figuren uit MATLAB kunnen omgezet worden in een pdf bestand. Dat pdf bestand kan dan als
graphic in Lyx geïmporteerd worden. Om in Matlab een figuur om te zetten naar pdf kan gebruik
gemaakt worden van de volgende m-file1:
function makepdf(file ,figuresize ,h)
% MAKEPDF exports a figure to PDF
% file: filename of the destination (default: MATLAB.pdf)
% figuresize: [W H] vector expressed (default: [10 10])
% h: figure handle (default: gcf)
if nargin < 3

h = gcf;
if nargin < 2

figuresize = [10 10];
if nargin == 0

file = ’MATLAB.pdf’;
end;

end;
end;
set(h,’PaperUnits ’,’centimeters ’);
set(h,’PaperSize ’,figuresize);
set(h,’PaperPosition ’ ,[0 0 figuresize ]);
print(h,’-dpdf’,file);

Het is meestal een beetje spelen met de figuresize parameter om de letters van de assen groot
genoeg te maken ten opzichte van de figuur zelf.

Voor figuren met veel data kunnen de pdf files die gegenereerd worden door de makepdf te groot
worden om vlot getoond te worden in de uiteindelijke pdf. Als dit gebeurt wordt best overgegaan van
pdf naar png. Dit kan gedaan worden door in de laatste lijn code van de makepdf functie de parameter
’-dpdf’ te veranderen in ’dpng’. Het resultaat is wel minder mooi dan het werken met de pdf.

3.3.2 Vanuit ADS

Voor het kopiëren uit de schematic window is dit een slechte oplossing, maar de enige oplossing.
De lijnen van de schema’s zullen er slecht uitzien. Voor resultaten van simulaties is het best om
de resultaten te exporteren naar MATLAB met het MatlabOutput blokje in ADS2011 en de figuren

1Danku Egon voor de makepdf
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degelijk te maken in MATLAB. Voor schema’s en schakelingen worden best gewoon in incscape gemaakt
voor het mooiste resultaat.

Als er niks anders op zit kan de volgende methode gebruikt worden om dingen rechtstreeks uit ADS
naar Lyx te kopiëren:

1. Selecteer en kopieer de componenten uit schematic mode of de graph die ge wilt kopieren

2. doe ctrl + v in de gewenste float in Lyx

3. Lyx vraagt om de afbeelding op te slaan als .emf afbeelding. doe dit

4 Wiskundige formules
Lyx is beestig handig voor het invoegen van wiskundige formules in een text. De Math mode kan
gebruikt worden zoals in word, door alles aan te klikken, of zoals in pure tech, door alles in code te
typen. Uiteindelijk is een mix van beide de snelste manier om te werken, omdat de dingen als delingen,
subscripts en superscripts veel voorkomen en dus het best in code getypt worden, terwijl ingewikkeldere
dingen zoals stelsels en matrices gemakkelijker ’op zijn Words’ ingevoegd worden door te klikken. Er
zijn veel verschillende types formules, maar ik gebruik er maar twee van: de inline formula en de
Numbered formula.

4.1 Inline formula
• De inline formula staat in een paragraaf zelf en krijgt geen nummers. een simpel voorbeeldje

is a = b+ c.

• Gerbuik ctrl+m om tijdens het typen in math mode te gaan. op die manier moet ge niet klikken

• gerbuik spatie om terug uit math mode te gaan, ook handig

• Typ alle variabelen waar naar verwezen zordt in een tekst ook in math mode, zodat het lettertype
overeen komt. dit verhoogt de leesbaarheid

4.2 Numbered formula
• De numbered formula staat tussen paragrafen en heeft een nummer dat automatisch gegenereerd

wordt. Sneltoets is ctrl + alt+ n (ik moet iterio een pint)

voorbeeld = a+ b (1)

• Ik ken geen snelkoppeling om ze in te voeren. gebruik Insert→Math→ Numbered formula

4.3 Handige codes in math mode
• subscript: Ai typ A_i

• superscript: Ai typ A^i

• breuk: a
b typ \frac, duw spatie en dan kunnen de teller en noemer getypt worden

9



• Griekse kleine letters: αβγ typ \ en dan de naam van de griekse letter: bvb \alpha \beta \gamma

• Griekse grote letters: ΓΩ typ \ en dan de naam van de griekse letter met een hoofdletter. bvb:
\Gamma \Omega

• Vierkantswortel:
√
a typ \sqrt en druk spatie

• spatie werkt niet in math mode (het wordt gebuikt om uit math mode te gaan). gebruik ctrl +
spatie in de plaats

• getypte codes worden aangevuld. duw tab om de code te laten afwerken \rightarrow kan bij mij
snel gedaan worden door \r te typen en dan tab te duwen

• ...

4.4 Extra

4.4.1 Haakjes

Om haakjes in te voeren die meeschalen met de formules kunnen de haakjesknoppen gebruikt worden:

De eerste drie knoppen zijn de meest gebruikte haakjes, de vierde knop laat toe om speciallekes te
maken en ook assymetrische haakjes. Vergeet dan niet het ’Keep matched’ vinkje uit te zetten.

4.4.2 Stelsels

Stelsels invoegen gebeurt met de ’stelsel’ knop

Als erop gedrukt wordt bekom je het volgende:

Het is de bedoeling dat in het linkerkadertje de vergelijking ingevoerd wordt. het rechterkadertje
dient voor commentaar (denk ik). Om een vergelijking toe te voegen, moet je op de ’voeg vergelijking
toe’ knop duwen.
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4.4.3 matrices

Om matrices in te voegen, gebruik de matrix knop:

Er zal een menu verschijnen waar het aantal rijen en kolommen gevraagd wordt. Vergeet geen
haakjes toe te voegen op de manier die eerder uit de doeken gedaan werd.

4.5 Andere Math modes (AMS)

TODO

5 Labels en Cross-References

Een van de grootste voordelen van Lyx s de overzichtelijke manier waarop met cross-referenties gewerkt
wordt. Een cross-referentie verwijst altijd naar een label dat ergens in de text staat. Op die manier,
als het nummer van een formule of een figuur verandert, blijft de verwijzing ernaar correct.

5.1 Label invoegen

Een label toevoegen is heel simpel:

1. Insert→ Label...

2. Geef de naam voor het label op

3. druk OK.

Lyx bepaalt het type van label in functie van de plaats waar de cursor staat op het moment dat
het label ingevoerd wordt. Een label bij een figuur begint met ’fig:’, een label naar een genummerde
vergelijking begint met ’eq:’... Er zal een grijs kadertje verschijnen op de plaats waar het label naar
verwijst met de naam van het label erin.

5.2 Cross reference invoegen

Een cross-reference invoegen is zowaar nog gemakkelijker:

1. Instert→ Cross−Reference...

2. Kies het gewenste label uit de lijst met labels

3. Druk OK.

In de tekst zal nu een grijs kadertje verschijnen met de naam van het label. In de uiteindelijke PDF zal
dit vertaald worden in een nummer, dus zorg er zeker voor dat je zelf nog zegt waarnaar er verwezen
wordt. bvb in “figuur <cross-reference> zien we ...”.
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5.3 Label invoegen bij numbered formula’s
Bij numbered formula’s is het invoegen van een label een beetje anders:

1. Rechts-klik op het nummer van de formule

2. klik op ’equation label ’

3. typ naam en druk OK

6 Tabellen
Tabellen worden net als figuren in een float geplaatst. In plaats van een figure float te gebuiken moet
nu een table float gebruikt worden. In de float kan dan een tabel toegevoegd worden:

1. Insert→ Float→ Table

2. Zet de cursor in de float

3. Insert→ Table...

4. Kies het aantal rijen en kolommen en druk OK.

Net als in math mode verschijnen er verschillende opties onderaan in beeld als er op de tabel geklikt
wordt.

6.1 Code plaatsen in Lyx documenten
Codevoorbeelden kunnen geplaatst worden en gekleurd worden volgens de regels van de kunst door
gebruik te maken van Listings en over de juiste LATEX code te beschikken die de regels bevatten om code
te kleuren. De MATLAB code die de makepdf functie beschreef in het deel over figuren is geplaatst
op die manier. De code die daar gebruikt werd is LATEX code. Ze kan in Lyx ingevoerd worden met
ctrl + L

\lstinputlisting[style=matlab ]{ makepdf.m}

De m-file makepdf.m werd in dezelfde map geplaatst als de Lyx File. Er kan een (relatief)pad
ingegeven worden in de accolades, dus het is mogelijk om een map te maken met codevooorbeelden.

Om van de matlab style gebruik te maken wordt het bestand MATLABCODE.inc.tex2 in dezelfde
map geplaatst als het Lyx bestand en wordt de volgende lijn aan de LATEX preamble toegevoegd:

• Document→ Settings...→ LaTeX preample

• Voeg de code \input{MATLABcode.inc.tex} toe aan de preamble.

Als er geen bestandje beschikbaar is met de code en als de code gewoon getypt moet worden in Lyx
kan gebruik gemaakt worden van program listings:

• Insert→ ProgramListing

• Er verschijnt een kadertje, daarin kan de code geplaatst worden
2Bedankt aan Egon om de LATEX code te leveren die in dit bestand staat
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Om de style hiervan in te stellen voer je de volgende stappen uit:

• rechtermuisklik op het kadertje met code

• Settings...→ Advanced

• Typ rechts ’style=matlab’

en de code zal volgens de MATLAB regels gekleurd worden. Als een andere programmeertaal moet
weergegeven worden zal je moeten zoeken naar de LATEX regels om die code te formatten. Inspiratie
kan opgedaan worden door in het MATLABcode.inc.tex bestand te gaan lezen.

Een andere optie is het gebruik van verbatim, maar daarvoor moet in LATEX code gewerkt worden
(ctrl + L):

\begin{verbatim}
plaats code hier
\end{verbatim}

6.2 VUB titelblad

Een thesis moet een titelblad hebben. Dat titelblad moet in de VUB huisstijl. Om met Lyx in de
VUB huisstijl een titelblad te maken heeft Egon ons een paar bestandjes gegeven die daarvoor gebruikt
kunnen worden. Ik steek die bestanden bij de cursus.

• Begin met het plaatsen van die bestanden in dezelfde map als de lyx file.

6.2.1 Toevoegen in LATEX preamble

• Document→ Settings...→ LaTeX preamble

• Voeg \input{propertiespreamble.inc.tex} toe aan de preamble

6.2.2 in document zelf

bovenaan in het document moet de volgende LATEX code komen (ctrl + L):

• \maketitlepage

6.2.3 In propertiespreamble.inc.tex

In dit bestand staan de gegevens die op het titelblad getoond zullen worden. Pas de auteur, titel,
promotor, jaar en mogelijk departement, faculteit en reden (diploma) aan.

7 Citations

Verwijzingen naar de literatuur gebeuren niet met een lijst gecombineerd met labels en cross references.
hiervoor hebben ze een ander systeem uitgedacht.
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7.1 Bibliografie toevoegen

Om te beginnen met een citation moet er een bibliografie toegevoegd worden.

1. Zet de cursor ergens in de teskt (liefst ergens vanachter waar de bibliografie gaat komen uitein-
delijk).

2. stel het teksttype in op ’Bibliography’ . Er verschijnt een label van de vorm key [label].

3. Typ de juiste referentie naar het paper achter dit label.

4. Om alles overzichtelijk te houden, klik op het label en geef het veldje Key een naam die duidelijker
weergeeft over welke verwijzing het gaat. Blijf van het label veldje af, daar komt alleen maar
miserie van.

5. Door enter te duwen kunnen meer labels aangemaakt worden voor meer referenties

7.2 Citation doen naar referentie in bibliografie

Als de referenties in de bibliografie staan is het gemakkelijk om er een verwijzing naar te doen:

1. Instert→ Citation...

2. Kies de gewenste referentie(s)

3. druk OK

Deze referenties zullen in de tekst verschijnen als [3].

8 Citations Advanced: BibTEX

Voor kleine documenten volstaat het systeem van de vorige section om referenties te doen. Voor grotere
documenten, of als je gemakkelijk in verschillende documenten naar dezelfde artikels wilt verwijzen
kan een BibTEX database heel handig zijn. In een BibTEX database zijn de gegevens voor de citation
van een artikel of boek opgeslaan onder het volgende formaat:
@ARTICLE{Tsividis1994 ,
author = {Yannis Tsividis},
title = {Integrated Continuous -Time Filter Design -An Overview},
journal = {IEEE Journal of Solid -State Circuits},
year = {1994} ,
volume = {29},
pages = {166 -175} ,
number = {3},
month = {March},
}

In Lyx is het dan mogelijk om IEEE referentie stijl te selecteren. Deze zet de referenties dan om
in de juiste vorm in de bibliografie. Natuurlijk is de manier waarop die referenties opgeslaan zijn in de
BibTEX database totaal onoverzichtelijk, maar daar hebben we JabRef voor
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Figuur 1: JabRef Interface

8.1 JabRef

Op de computers op het 6de verdiep staat JabRef geinstalleerd als editor voor BibTEX databases,
daarom gebruik ik die ook, er zijn andere tools beschikbaar, maar JabRef werkt goed, dus gebruik dat
ook maar. De interface van JabRef voor mijn database met papers en boeken wordt getoond in figuur
1.

De eerste keer dat JabRef gestart wordt moeten jullie een nieuwe database aanmaken. Geef ze een
mooie naam, want ze zal nog veel gebruikt worden. Nu kan je beginnen met het toevoegen van artikels.
Er zijn twee manieren om dit te doen. De eerste manier is in JabRef zelf en is volledig handmatig. De
andere werkt met BibTEX code die op IEEExplore kan gedownload worden.

8.1.1 Methode 1: JabRef zelf

Er zijn verschillende categorieën beschikbaar. Afhankelijk van welke categorie zijn de vereiste cellen
anders. De meest gebruikte categorieën zijn Article, Book en Inproceedings. Om een paper of boek
aan de database toe te voegen moet gewoon op het groen plusje bovenaan geklikt worden, kies dan de
categorie en vul al de gegevens in die onder de tab required field staan.

• Als het paper meerdere auteurs heeft moet er ’and’ tussen alle namen staan staan. Het beste
formaat voor een naam is: achternaam eerst, dan een komma en dan de voornaam. Op die manier
weet BibTEX hoe de naam afgekort moet worden, zelf als de achternaam uit twee woorden bestaat.

• De key is heel belangrijk. Ik neem de achternaam van de auteur en dan het jaar van het paper
(als er meerdere papers zijn dat jaar voeg ik nog a,b,... toe)

• Het is mogelijk om het pdf bestand van het paper aan de database te linken. Op die manier is
het mogelijk om het bestand vanuit JabRef te openen en het laat toe om beter te zoeken in de
papers dan gewoon in windows.
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• Als de naam van het bestand begint met de key uit de BibTEX database kan JabRef normaal
het bijhorende bestand automatisch vinden. Geef het pad van de map waar de papers (of
mappen met papers in) zijn opgeslaan in op de volgende plaats Options → Preferences →
External Programs→MainFileDirectory

8.1.2 Methode 2: IEEExplore

Bij elk artikel op IEEEexplore is het mogelijk om de BibTEX code die bij dat artikel hoort te laten
zien (maak een account aan, dan kan je die te zien krijgen). Die code kan simpelweg buiten JabRef in
de BibTEX database geplakt worden als de database geopend wordt met kladblok.

8.2 Invoeren in Lyx
Het is niet moeilijk om de BibTEX database in Lyx binnen te krijgen. Het enige probleem is dat
de standaard opslagmethode in JabRef niet gebruikt kan worden door Lyx en rare errors geeft. Stel
JabRef in om de database in UTF-8 op te slaan: Options → Preferences → General → Encoding
moet op UTF8 staan. Save de database en open het bestand waar de database in gebruikt moet
worden in Lyx.

• Zet de cursor op de plaats waar de Bibliografie in het bestand moet komen (meestal op het einde)

• Insert→ List/TOC → BibTeX Bibliography...

• Klik Add

• Browse naar de .bib file

• Stel de style in op de manier waarop de referenties weergegeven moeten worden (IEEEtrans zit
ertussen)

• Content moet op ’All cited references’ staan

Het invoeren van citations gaat nu op dezelfde manier als ervoor, maar nu zou de lijst die je te zien
krijgt veel groter moeten zijn omdat de volledige database is toegevoegd aan het Lyx bestand.

9 Presentaties maken met Lyx
Presentaties maken in LATEX wordt gedaan met Beamer. In Lyx is dit niet anders. De presentaties
die gemaakt kunnen worden met Lyx zien er meestal simpel uit, verwacht geen speciale effecten of
ingewikkelde lay-out, de voordelen van een Lyx presentatie zijn dat ze heel snel gemaakt kunnen worden
en op de slides worden links geplaatst die toelaten om binnen de slides te springen naar verschillende
hoofdstukken of secties.

9.1 Beamer en LATEX preamble
Om te beginnen zet je de lay-out op ’presentation (beamer)’

• Document→ Settings...→ DocumentClass

• Zet ’Document class’ op ’presentation (beamer)’
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• Om de balken boven en onder kleiner te maken, voeg ’compress’ toe aan de custom class options.

De opties die ik aan de LATEX preamble toegevoegd heb voor mijn thesispresentatie zijn de volgende

\usetheme[]{Luebeck}
\useoutertheme{split}
\setbeamertemplate{navigation symbols}{}

Om weg te gaan van de standaard beamer presentatiestijl (en bijvoorbeeld de VUB huisstijl te
nemen) moeten de volgende lijnen code aan de LATEX Preamble toegevoegd worden

\usecolortheme{vub}
\input{settings.inc.tex}
\logo{\includegraphics[width=3cm]{VUB_schild}}

De voorbeelden code die vanaf nu gegeven worden zijn enkel uitgetest op de VUB stijl, voor de
andere lay-out stijlen zal aanpassing nodig zijn

9.2 Titelpagina
De titelpagina wordt best in LATEX code toegevoegd aan het begin van het document.

Beginnen met de titel. Er zijn twee delen aan de titel: de titel zelf en de optionele titel die onderaan
op elke slide getoond wordt. De syntax is

\title[optionele titel]{Titel}

In mijn thesispresentatie heb ik in de optionele titel het paginanummer gezet. Dit geeft de volgende
LATEX code in het begin van het document.

\title[Master’s thesis \hspace{14em} \textbf{\insertpagenumber} / \insertdocumentendpage] {Design and Analysis of an On-Chip\\Programmable Op-Amp based Filter}

Tijd om de auteur, instelling en datum van de presentatie toe te voegen. Dit kan met de volgende
code in het begin van het document

\author{Adam Cooman}
\institute{Vrije Universiteit Brussel}
\date{June 27, 2012}

En nu (eindelijk) is het tijd om de titelslide te maken. Dit doen we opnieuw met LATEX code.

\begin{frame}
\includegraphics[height=1cm]{VUB_logo}
\titlepage
\begin{tabular}{ll}
\textbf{Promotor} & Prof. Dr. ir. Gerd Vandersteen\\
\end{tabular}
\end{frame}
\logo{}

Het VUB logo wordt nog is toegevoegd met het includegraphics commando. Dan wordt de infor-
matie zoals titel auteur, instelling en datum toegevoegd met het titlepage commando. De promotor
wordt best in een tabelletje zonder randen geplaatst en tenslotte wordt het logo van de VUB (dat in
de preamble gespecifieerd is) nog is toegevoegd aan de slide.
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Figuur 2: Nut van sections en subsections bij het maken van presentaties

9.3 Sections en Subsections

Sections en Subsections hebben niet verschrikkelijk veel nut in een presentatie. Hun grootste nut is
om toe te laten gemakkelijk te springen in de presentatie, overzicht te geven aan het publiek in welk
stuk van de presentatie we ons bevinden (en hoe lang ze nog moeten uitzitten) en om automatisch een
inhoudstabel te kunnen genereren. Al deze dingen worden getoond in Figuur 2.

De sections van de presentatie worden getoond bovenaan links en de huidige section wordt in het
wit getoond om aan te duiden dat we ons in die section bevinden. Het is duidelijk dat er niet veel
plaats is om de titels van de sections weer te geven daarboven. Daarom wordt eigenlijk niet de echte
titel van de section getoond, maar de ’short title’ van de section als die beschikbaar is.

Om een short title toe te voegen aan een section of subsection title doe je:

• Zet de cursor na de section of subsection titel

• Insert→ Short T itle

• Er verschijnt een ’opt’ vakje. Typ daarin de korte naam voor de section of subsection.

9.4 Slides en Frames

Een presentatie bestaat uit frames die dan in de pdf een of meerdere slides vormen (zie animatie).
Om een frame te beginnen plaats je de cursor in de gewenste (sub)section en zet je de lay-out op
BeginFrame. Er verschijnt een bordeau woord ’Frame’ Daarna kan je de titel van de frame typen.
Deze zal bovenaan de slide verschijnen. Daarna kan je de inhoud van de frame toevoegen alsof het een
echte pagina is.
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Figuur 3: Kolommen in een Slide in Lyx

9.4.1 Kolommen

Om de lay-out van slides onder controle te houden zijn kolommen meestal heel handig. Het invoeren
van kolommen is wel verschikkelijk geïmplementeerd in lyx.

Het uiteindelijke doel dat we willen bekomen is getoond in figuur 3. De kolommen zijn geïmple-
menteerd in Lyx als een lijst (itemize) met verschillende niveaus. De knoppen om het niveau in de

lijst aan te passen en zullen dus veel gebruikt moeten worden.

• Zet de cursor op de plaats waar de kolommen moeten staan

• Zet de lay-out op Columns (of ColumnsTopAligned of ColumnsCenterAligned)

• Druk Enter

• Increase Depth (er verschijnt een lijntje links)

• Zet de lay-out op Column

• Typ de latex code die de breedte van de kolom geeft (ctrl + L en 0.5\columnwidth)

• Druk enter

• Increase Depth en zet de lay-out op standaard

• Typ de inhoud van de eerste kolom

• Druk enter

• Increase Depth

• zet de lay-out op column en typ opnieuw de LATEX code om de breedte in te geven

• Druk enter

• Increase Depth en zet de lay-out op standaard

• Typ de inhoud van de tweede kolom

Let tijdens het maken en het typen van de kolommen altijd op het lijntje links. Dat lijntje moet
doorlopen over alle kolommen én hun inhoud. Enkel dan zal het werken. Als het lijntje onderbroken

wordt kan dit opgelost worden met de Increase Depth knop.
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9.4.2 Handige dingen bij het maken van slides

• In slides, plaats figuren NOOIT in een float. Dit is voor niks nodig en maakt het controleren van
de lay-out alleen maar moeilijker.

• Maak gebruik van hspace en vspace om de plaatsing van objecten te controleren (er kunnen ook
negatieve waarden ingegeven worden in de hspace en vspace, die zijn extreem handig als er veel
op een slide moet)

• Gebruik itemize, dat maakt alles overzichtelijk

• Gebruik de template die beschikbaar is in Lyx om inspiratie op te doen voor het maken van de
slides File→ NewFromTemplate...→ beamer − conference− ornate− 20min.lyx

9.5 ’Animatie’
De animatie in een Lyx presentatie is bij mijn weten beperkt tot het laten verschijnen van inhoud bij
een muisklik.

9.5.1 Pause

De meest simpele manier om daarvoor te zorgen is door gebruik te maken van de pause lay-out:

• Zet de cursor voor het stuk dat moet verschijnen na de muisklik

• Zet de lay-out op ’Pause’

• Er verschijnt een horizontale stippellijk

Alles na de stippellijn zal verschijnen na een klik. Eigenlijk worden nu voor de frame in Lyx twee
pagina’s in pdf gemaakt, een met alle inhoud voor de pause streep en een tweede met alles erop, ook
de inhoud na de pause streep.

Ingewikkeldere ’animaties’ kunnen ingevoerd worden met LATEX code:

9.5.2 Alt

Om iets te vervangen op een klik moet gebruik gemaakt worden van het alt commando. De syntax is
de volgende:

\alt<slidenummers>{text}{alternatieve tekst}

Deze LATEX code zal ervoor zorgen dat de text getoond wordt op de slidenummers die opgegeven zijn
en anders zal de alternatieve tekst getoond worden. De slidenummers worden ingegeven, gescheiden
met een komma en zijn opgegeven binnen een frame. bijvoorbeeld

\alt<2,3>{adam}{???}

Zal eerst (op slide 1, dus bij het verschijnen van de eerste slide van de frame) de tekst ’???’ laten
zien. Bij een klik komen we op slide 2 en zal dus de tekst ’adam’ getoond worden.

Het klikken zelf wordt niet toegevoegd door het alt commando. Het is dus nodig om ergens in de
frame een Pause te hebben die ervoor zorgt dat de frame in verschillende slides onderverdeeld wordt.
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9.5.3 Only

Only is gelijkaardig aan Alt, maar naar mijn mening handiger voor grote blokken inhoud. De syntax
is de volgende

\only<slidenr>{inhoud}

Dit commando zal de inhoud enkel laten zien op de slide binnen de frame die gegeven is door het
slidenummer. Only maakt wel de aparte slides aan en kan dus gebruikt worden zonder pause.

9.6 Handouts
Omdat alle animatie die toegevoegd wordt elke keer een nieuwe slide maakt in de pdf neemt het aantal
pagina’s snel toe. Bij het printen van hand-outs moet al die animatie ook niet mee afgeprint worden.
Om alle animatie af te zetten kan de ’handout’ optie meegegeven worden aan de document class. De
pdf die dan gecomplileerd wordt kan dan dienen als hand-outs. Vergeet de handout optie niet weg te
halen als de presentatie zelf gemaakt wordt, anders zijn alle mooie animaties weg.

• Document→ Settings...→ DocumentClass

• Voeg ’handout’ toe aan de custom class options. Als er al iets staat, scheid de options met een
komma

10 CV maken met Lyx
Een CV kan gemakkelijk gemaakt worden met de europecv lay-out stijl. Maak een nieuw document aan
en stel bij document settings→ DocumentClass de document class in op curriculumvitae (Europe)
(de andere twee die beschikbaar zijn trekken naar mijn mening op niks).

Na de Document class in te stellen is het best om in het vakje Custom de volgende parameters
mee te geven: nologo, notitle. Deze parameters verwijderen het europecv logo en de titel die anders
standaard door de lay-out toegevoegd worden. Het ziet er allemaal beter uit zonder.

10.1 Language en encoding instellen
Het is best om te beginnen bij het instellen van de taal van het document. Dit kan gedaan worden in
Document→ Settings...→ Language.

HEEL BELANGRIJK: zet de encoding op Unicode (ucs − extended) (utf8x). anders zal het
bestand niet compileren

10.2 LATEX Preamble
De belangrijkste gegevens, zoals naam, adres, telefoonnummer,... staan in de LATEX Preamble (Document→
Settings...→ LaTeX Preamble). Voeg de volgende lijnen LATEX code toe in de preamble

\usepackage{graphicx}
\ecvname{Cooman Adam}
\ecvfootername{Cooman Adam}
\ecvaddress{Straat Nummer \newline Postcode Stad \newline Land}
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\ecvtelephone[Mobiel telefoonnummer]{Vast telefoonnummer}
\ecvemail{email}
\ecvnationality{nationaliteit}
\ecvdateofbirth{Geboortedatum}
\ecvgender{Geslacht}

Om een foto toe te voegen steek je de foto in dezelfde map als de .lyx file waar je in werkt en voeg je
de volgende LATEX code toe aan de preamble

\ecvpicture[height=5cm]{foto.jpg}

En dan, om de tekst langs de foto te plaatsen is het best om een negatieve vertical space toe te voegen.
Dit kan door de volgende LATEX code toe te voegen aan de Preamble

\ecvafterpicture{\ecvspace{-6cm}}

Hiermee is het werk in de preamble klaar.

10.3 Lyx Zelf

Door de document class op ’curriculum vitae (Europe)’ te zetten zijn de keuzes voor lay-out nu totaal
anders geworden.

10.3.1 Begin PersonalInfo en End

Begin met het toevoegen van het begin van de cv door de lay-out stijl op ’begin’ te zetten in plaats
van standard. Druk enter en voeg de personal info toe die in de preamble ingevuld is door de lay-out
stijl op ’personalInfo’ te zetten. Voeg het einde van het cv toe door op het einde van het document de
lay-out op ’End’ te zetten.

10.3.2 Sections met Items

(a) in pdf

(b) Overeenstemmende Lyx code

Figuur 4: Voorbeeld van een section met twee items
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Naast de personal info bestaat de cv uit sections met daarin items met gegevens. Een voorbeeld
van zo’n section en de overeenstemmende code in lyx staat getoond in figuur 4. De sections worden
op dezelfde manier ingevoerd als is een gewone tekst, de items zijn iets anders.

Net als een section kan je een item invoeren via de lay-out keuzes. Een item in het europecv
bestaat uit twee delen: de titel en de beschrijving. Ze worden gescheiden door twee accolades: }{. Die
accolades moeten ingevoerd worden als LATEX code in het lyx document. Om LATEX code in te voeren
gebruik je best ctrl + L.

10.3.3 Talen

(a) Tabel in pdf

(b) Code in Lyx

Figuur 5: Talentabel

Om de talenkennis weer te geven is er een speciale tabel in de lay-out beschikbaar. De Lyx code ervan
wordt getoond in figuur 5. Zoals je kan zien bestaat het grootste deel ervan uit LATEX code (ingeven
met ctrl + L).

• Begin met het ingeven van de moedertaal: zet de lay-out op ’MotherTongue’ en typ de moedertaal
erna

• Voeg de Language Header toe. Zet de lay-out op ’LangHeader’ en typ erna het tekentje dat moet
gebruikt worden om naar de footer te verwijzen

• Voeg de talen toe. Zet de lay-out op ’language’ en typ de taal die beschreven wordt. Voeg dan
de volgende LATEX code toe:

}{\ecvCOne}{\ecvCOne}{\ecvBTwo}{\ecvBTwo}{\ecvCOne
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Waarbij voor de taalniveaus kan gekozen worden tussen \ecvCOne, \ecvCTwo, \ecvBOne, \ecvBTwo,
\ecvAOne en \ecvATwo. De beschrijving van de taalniveaus staat op wikipedia LINK . De volgorde
voor het ingeven van de niveaus is hetzelfde als die in de voorbeeld pdf (Figuur 5).

• Voor de laatste taal moet ’LastLanguage’ gebruikt worden. Voor de rest is alles hetzelfde.

• Voeg tenslotte de Language Footer toe. zet de lay-out op ’LangFooter’ en typ hetzelfde tekentje
als bij de language header.

11 Extra

11.1 Exporteren naar PDF
Exporteren naar PDF gaat als volgt:

1. File→ Export→ PDF (pdflatex)

2. Browse naar de gewenste map

3. klik OK

Het is mogelijk om het document te previewen door V iew → V iew [PDF (pdflatex)] of door ctrl + r
te gebruiken. Pas op dat het PDF document zelf niet open staat, anders zal er een error verschijnen.
Als het document groot wordt en het compileren lang duurt kan V iew → Update [PDF (pdflatex)]
gedaan worden of ctrl + shift+ r gebruikt worden om tijd uit te sparen (werkt niet alijd).

11.2 Extra van de extra
• Inhoudstafels, lijsten van figuren, algoritmes, termen,... staan allemaal in de categorie List/TOC

bij insert. gebruik Insert → List/TOC → keuze om een van die dingen in te voegen. Het is
mogelijk om in Document → Settings... → Numbering&TOC in te stellen hoe diep de table
of contents de titels moet weergeven. Het is ook mogelijk om daar de diepte van nummering aan
te passen. Op die manier kan ervoor gezorgd worden dat ’paragraph’ en ’subparagraph’ ook een
nummer krijgen. Dit is standaard niet zo.

• Voetnoten kunnen ingevoerd worden door gebruik te maken van Insert → Footnote. Er zal
een kadertje verschijnen in de tekst op de plaats waar de voetnoot bijhoort. De inhoud van het
kadertje wordt onderaan de pagina weergegeven.

• Index entries zijn handig om op het einde van een tekst een lijst te maken met een overzicht
waar de lezer de uitleg van bepaalde termen kan vinden. Het invoeren van die index lijst gebeurt
net als het invoeren van een inhoudstafel. Voeg een index entry in door het gewenste woord te
selecteren en Insert→ IndexEntry te doen. De tekst in het kadertje dat verschijnt komt in de
index, de plaats waar het kadertje staat is de locatie waar de index naar verwijst.

• Om lijsten te maken worden Itemize en Enumerate gebruikt. Itemize is een lijst met bolletjes,
enumerate bevat getalletjes vooraan de lijst. Description laat toe om een lijst met termen te
maken waar dan telken een beschrijving bij komt te staan

• Page Break en New page staan onder Insert→ Formatting
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• Het is mogelijk om een real-time spell checker in te stellen in Tools → Preferences... →
Languages→ Spellchecker. Zet daar het vinkje ’Spellcheck continuously’ aan.

• Om een lijst met afkortingen te maken in het begin van een bestand kunnen Nomenclature Entries
gebruikt worden. Om wiskundige tekens daar in te geven moet wel gebruik gemaakt worden van
LATEX code om de tekens te genereren.
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